Welcome to the UK List of
TeX Frequently Asked Questions
on the Web

Searching

The index of Frequently Asked Questions about TeX is searchable.

Please enter your keyword here:   then press here: ,    or:
Google

PDFTeX destination … ignored

The warning:

! pdfTeX warning (ext4): destination with the same identifier
(name{page.1}) has been already used, duplicate ignored

arises because of duplicate page numbers in your document. The problem is usually soluble: see PDF page destinations — which answer also describes the problem in more detail.

If the identifier in the message is different, for example name{figure.1.1}, the problem is (often) due to a problem of package interaction. The README in the hyperref distribution mentions some of these issues — for example, equation and eqnarray as supplied by the amsmath package; means of working around the problem are typically supplied there.

Some packages are simply incompatible with hyperref, but most work simply by ignoring it. In most cases, therefore, you should load your package before you load hyperref, and hyperref will patch things up so that they work, so you can utilise your (patched) package after loading both:

\usepackage{your package}
...
\usepackage[opts]{hyperref}
...
<code that uses your package>

For example:

\usepackage{float}          % defines \newfloat
...
\usepackage[...]{hyperref}  % patches \newfloat
...
\newfloat{...}{...}{...}

You should load packages in this order as a matter of course, unless the documentation of a package says you must load it after hyperref. (There are few packages that require to be loaded after hyperref: one such is memoir’s “hyperref fixup” package memhfixc.)

If loading your packages in the (seemingly) “correct” order doesn’t solve the problem, you need to seek further help.


Go to previous question, or next question

Go to FAQ home.

URL for this question: http://www.tex.ac.uk/cgi-bin/texfaq2html?label=hyperdupdest

Comments, suggestions, or error reports? - see “how to improve the FAQ”.

This is FAQ version 3.28, released on 2014-06-10.